#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^<w:p>(.*?)<\/w:p>$"
Local $sString = "<w:p> abc </w:p>" & @CRLF & _
"<w:p> def </w:p>" & @CRLF & _
"<w:tr #A1b2c3> <w:p> 123 </w:p> </w:tr>" & @CRLF & _
"<w:tr #C1d2e3> <w:p> 456 </w:p> </w:tr>" & @CRLF & _
"<w:p> ghi </w:p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")