using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^<w:p>(.*?)<\/w:p>$";
string input = @"<w:p> abc </w:p>
<w:p> def </w:p>
<w:tr #A1b2c3> <w:p> 123 </w:p> </w:tr>
<w:tr #C1d2e3> <w:p> 456 </w:p> </w:tr>
<w:p> ghi </w:p>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}