import re
regex = re.compile(r"^<w:p>(.*?)<\/w:p>$", flags=re.MULTILINE)
test_str = ("<w:p> abc </w:p>\n"
"<w:p> def </w:p>\n"
"<w:tr #A1b2c3> <w:p> 123 </w:p> </w:tr>\n"
"<w:tr #C1d2e3> <w:p> 456 </w:p> </w:tr>\n"
"<w:p> ghi </w:p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")