// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^<w:p>(.*?)<\/w:p>$").unwrap();
let string = "<w:p> abc </w:p>
<w:p> def </w:p>
<w:tr #A1b2c3> <w:p> 123 </w:p> </w:tr>
<w:tr #C1d2e3> <w:p> 456 </w:p> </w:tr>
<w:p> ghi </w:p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}