$re = '/^<w:p>(.*?)<\/w:p>$/m';
$str = '<w:p> abc </w:p>
<w:p> def </w:p>
<w:tr #A1b2c3> <w:p> 123 </w:p> </w:tr>
<w:tr #C1d2e3> <w:p> 456 </w:p> </w:tr>
<w:p> ghi </w:p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);