re = /^<w:p>(.*?)<\/w:p>$/m
str = '<w:p> abc </w:p>
<w:p> def </w:p>
<w:tr #A1b2c3> <w:p> 123 </w:p> </w:tr>
<w:tr #C1d2e3> <w:p> 456 </w:p> </w:tr>
<w:p> ghi </w:p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end