# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Germany.*\K$/ <--------/gm;t' <<< "Copy_of_E2EDKA1003_PARTN
Copy_of_E2EDKA1003_PARTNsdf
Copy_of Germany _E2EDKA1003_PARTN
Copy_of_E2EDKA1003_PARTNsdfsdf
Copy_of_E2EDKA1003_PARTNs dfsdf
Copy_of_E2EDKA1003_PARTNfsd fsd f
Copy_of_Germany E2EDKA1003_PARTN sd fsd"