#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)Germany.*\K$"
Local $sString = "Copy_of_E2EDKA1003_PARTN" & @CRLF & _
"Copy_of_E2EDKA1003_PARTNsdf" & @CRLF & _
"Copy_of Germany _E2EDKA1003_PARTN" & @CRLF & _
"Copy_of_E2EDKA1003_PARTNsdfsdf" & @CRLF & _
"Copy_of_E2EDKA1003_PARTNs dfsdf" & @CRLF & _
"Copy_of_E2EDKA1003_PARTNfsd fsd f" & @CRLF & _
"Copy_of_Germany E2EDKA1003_PARTN sd fsd"
Local $sSubst = " <--------"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)