const regex = /Germany.*\K$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Germany.*\\K$', 'gm')
const str = `Copy_of_E2EDKA1003_PARTN
Copy_of_E2EDKA1003_PARTNsdf
Copy_of Germany _E2EDKA1003_PARTN
Copy_of_E2EDKA1003_PARTNsdfsdf
Copy_of_E2EDKA1003_PARTNs dfsdf
Copy_of_E2EDKA1003_PARTNfsd fsd f
Copy_of_Germany E2EDKA1003_PARTN sd fsd`;
const subst = ` <--------`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);