# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Germany.*\K$"
test_str = ("Copy_of_E2EDKA1003_PARTN\n"
"Copy_of_E2EDKA1003_PARTNsdf\n"
"Copy_of Germany _E2EDKA1003_PARTN\n"
"Copy_of_E2EDKA1003_PARTNsdfsdf\n"
"Copy_of_E2EDKA1003_PARTNs dfsdf\n"
"Copy_of_E2EDKA1003_PARTNfsd fsd f\n"
"Copy_of_Germany E2EDKA1003_PARTN sd fsd")
subst = " <--------"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.