re = /Germany.*\K$/m
str = 'Copy_of_E2EDKA1003_PARTN
Copy_of_E2EDKA1003_PARTNsdf
Copy_of Germany _E2EDKA1003_PARTN
Copy_of_E2EDKA1003_PARTNsdfsdf
Copy_of_E2EDKA1003_PARTNs dfsdf
Copy_of_E2EDKA1003_PARTNfsd fsd f
Copy_of_Germany E2EDKA1003_PARTN sd fsd'
subst = ' <--------'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result