use strict;
my $str = 'Copy_of_E2EDKA1003_PARTN
Copy_of_E2EDKA1003_PARTNsdf
Copy_of Germany _E2EDKA1003_PARTN
Copy_of_E2EDKA1003_PARTNsdfsdf
Copy_of_E2EDKA1003_PARTNs dfsdf
Copy_of_E2EDKA1003_PARTNfsd fsd f
Copy_of_Germany E2EDKA1003_PARTN sd fsd';
my $regex = qr/Germany.*\K$/mp;
my $subst = ' <--------';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";