#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)-?\b\d+(?:\.\d+)?(?:\|\-?\d+(?:\.\d+)?){3}\b"
Local $sString = "13|5|-1|3 or 5|5|0|3 or 13|4|1.5|1" & @CRLF & _
"" & @CRLF & _
"The string may also contain additional numbers and words; a full example looks like so:" & @CRLF & _
"" & @CRLF & _
"SOME STRING CONTENT 13|5|-1|3 MORE 1.6 CONTENT HERE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")