import re
regex = re.compile(r"-?\b\d+(?:\.\d+)?(?:\|\-?\d+(?:\.\d+)?){3}\b", flags=re.MULTILINE)
test_str = ("13|5|-1|3 or 5|5|0|3 or 13|4|1.5|1\n\n"
"The string may also contain additional numbers and words; a full example looks like so:\n\n"
"SOME STRING CONTENT 13|5|-1|3 MORE 1.6 CONTENT HERE")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")