re = /-?\b\d+(?:\.\d+)?(?:\|\-?\d+(?:\.\d+)?){3}\b/m
str = '13|5|-1|3 or 5|5|0|3 or 13|4|1.5|1
The string may also contain additional numbers and words; a full example looks like so:
SOME STRING CONTENT 13|5|-1|3 MORE 1.6 CONTENT HERE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end