const regex = /-?\b\d+(?:\.\d+)?(?:\|\-?\d+(?:\.\d+)?){3}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-?\\b\\d+(?:\\.\\d+)?(?:\\|\\-?\\d+(?:\\.\\d+)?){3}\\b', 'gm')
const str = `13|5|-1|3 or 5|5|0|3 or 13|4|1.5|1
The string may also contain additional numbers and words; a full example looks like so:
SOME STRING CONTENT 13|5|-1|3 MORE 1.6 CONTENT HERE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}