package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-?\b\d+(?:\.\d+)?(?:\|\-?\d+(?:\.\d+)?){3}\b`)
var str = `13|5|-1|3 or 5|5|0|3 or 13|4|1.5|1
The string may also contain additional numbers and words; a full example looks like so:
SOME STRING CONTENT 13|5|-1|3 MORE 1.6 CONTENT HERE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}