#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([A-Z0-9]+ - [A-Z0-9]+).*(\.\w+)$"
Local $sString = "ABC - A11B11 - Note.txt" & @CRLF & _
"ABC - A22B22 (Note).txt" & @CRLF & _
"ABC - A33B33 | Note.txt"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)