$re = '/^([A-Z0-9]+ - [A-Z0-9]+).*(\.\w+)$/m';
$str = 'ABC - A11B11 - Note.txt
ABC - A22B22 (Note).txt
ABC - A33B33 | Note.txt';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;