re = /^([A-Z0-9]+ - [A-Z0-9]+).*(\.\w+)$/m
str = 'ABC - A11B11 - Note.txt
ABC - A22B22 (Note).txt
ABC - A33B33 | Note.txt'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result