import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Z0-9]+ - [A-Z0-9]+).*(\\.\\w+)$";
final String string = "ABC - A11B11 - Note.txt\n"
+ "ABC - A22B22 (Note).txt\n"
+ "ABC - A33B33 | Note.txt";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}