# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([A-Z0-9]+ - [A-Z0-9]+).*(\.\w+)$"
test_str = ("ABC - A11B11 - Note.txt\n"
"ABC - A22B22 (Note).txt\n"
"ABC - A33B33 | Note.txt")
subst = "$1$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.