const regex = /^([A-Z0-9]+ - [A-Z0-9]+).*(\.\w+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Z0-9]+ - [A-Z0-9]+).*(\\.\\w+)$', 'gm')
const str = `ABC - A11B11 - Note.txt
ABC - A22B22 (Note).txt
ABC - A33B33 | Note.txt`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);