#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\s+,?\[([A-Za-z0-9]+)\]\s=\s([A-Za-z0-9\@]+),?"
Local $sString = " [UserLoginName] = @UserLoginName, " & @CRLF & _
" ,[UserExternalId] = @UserExternalId" & @CRLF & _
" ,[UserName] = @UserName" & @CRLF & _
" ,[Password] = @Password" & @CRLF & _
" ,[IsWindowsUser] = @IsWindowsUser" & @CRLF & _
" ,[Active] = @IsActive" & @CRLF & _
" ,[MustChangePassword] = @MustChangePassword" & @CRLF & _
" ,[PasswordExp] = @PasswordExp" & @CRLF & _
" ,[PasswordModifiedDate] = @PasswordModifiedDate" & @CRLF & _
" ,[PasswordPolicyName] = @PasswordPolicyName" & @CRLF & _
" ,[LoginTry] = @LoginTry" & @CRLF & _
" ,[PermissionsRefreshDate] = @PermissionsRefreshDate" & @CRLF & _
" ,[FirstName] = @FirstName" & @CRLF & _
" ,[LastName] = @LastName" & @CRLF & _
" ,[EmailAddress] = @EmailAddress" & @CRLF & _
" ,[DefaultStoreId] = @DefaultStoreId" & @CRLF & _
" ,[EmployeeNumber] = @EmployeeNumber" & @CRLF & _
" ,[Phone] = @Phone" & @CRLF & _
" ,[MobilePhone] = @MobilePhone" & @CRLF & _
" ,[Address1] = @Address1" & @CRLF & _
" ,[Address2] = @Address2" & @CRLF & _
" ,[PostalCode] = @PostalCode" & @CRLF & _
" ,[PostalAddress] = @PostalAddress" & @CRLF & _
" ,[Title] = @Title" & @CRLF & _
" ,[Language] = @Language" & @CRLF & _
" ,[BirthDate] = @BirthDate" & @CRLF & _
" ,[EmploymentDate] = @EmploymentDate" & @CRLF & _
" ,[ResignationDate] = @ResignationDate" & @CRLF & _
" ,[BankaccountNo] = @BankaccountNo" & @CRLF & _
" ,[SocialSecurityNo] = @SocialSecurityNo" & @CRLF & _
" ,[Comment] = @Comment" & @CRLF & _
" ,[Country] = @Country" & @CRLF & _
" ,[vudGUID] = @VudGUID" & @CRLF & _
" ,[CreatedByUserId] = @CreatedByUserId" & @CRLF & _
" ,[ModifiedByUserId] = @ModifiedByUserId" & @CRLF & _
" ,[CreatedDate] = @CreatedDate" & @CRLF & _
" ,[ModifiedDate] = @ModifiedDate" & @CRLF & _
" ,[UseSingleSignOn] = @UseSingleSignOn" & @CRLF & _
" ,[Salt] = @Salt" & @CRLF & _
" ,[IsSystemUser] = @IsSystemUser"
Local $sSubst = "[\1] = ISNULL(\2, [\1]),"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)