// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s+,?\[([A-Za-z0-9]+)\]\s=\s([A-Za-z0-9\@]+),?").unwrap();
let string = " [UserLoginName] = @UserLoginName,
,[UserExternalId] = @UserExternalId
,[UserName] = @UserName
,[Password] = @Password
,[IsWindowsUser] = @IsWindowsUser
,[Active] = @IsActive
,[MustChangePassword] = @MustChangePassword
,[PasswordExp] = @PasswordExp
,[PasswordModifiedDate] = @PasswordModifiedDate
,[PasswordPolicyName] = @PasswordPolicyName
,[LoginTry] = @LoginTry
,[PermissionsRefreshDate] = @PermissionsRefreshDate
,[FirstName] = @FirstName
,[LastName] = @LastName
,[EmailAddress] = @EmailAddress
,[DefaultStoreId] = @DefaultStoreId
,[EmployeeNumber] = @EmployeeNumber
,[Phone] = @Phone
,[MobilePhone] = @MobilePhone
,[Address1] = @Address1
,[Address2] = @Address2
,[PostalCode] = @PostalCode
,[PostalAddress] = @PostalAddress
,[Title] = @Title
,[Language] = @Language
,[BirthDate] = @BirthDate
,[EmploymentDate] = @EmploymentDate
,[ResignationDate] = @ResignationDate
,[BankaccountNo] = @BankaccountNo
,[SocialSecurityNo] = @SocialSecurityNo
,[Comment] = @Comment
,[Country] = @Country
,[vudGUID] = @VudGUID
,[CreatedByUserId] = @CreatedByUserId
,[ModifiedByUserId] = @ModifiedByUserId
,[CreatedDate] = @CreatedDate
,[ModifiedDate] = @ModifiedDate
,[UseSingleSignOn] = @UseSingleSignOn
,[Salt] = @Salt
,[IsSystemUser] = @IsSystemUser";
let substitution = "[\\1] = ISNULL(\\2, [\\1]),";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}