const regex = /^\s+,?\[([A-Za-z0-9]+)\]\s=\s([A-Za-z0-9\@]+),?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s+,?\\[([A-Za-z0-9]+)\\]\\s=\\s([A-Za-z0-9\\@]+),?', 'gm')
const str = ` [UserLoginName] = @UserLoginName,
,[UserExternalId] = @UserExternalId
,[UserName] = @UserName
,[Password] = @Password
,[IsWindowsUser] = @IsWindowsUser
,[Active] = @IsActive
,[MustChangePassword] = @MustChangePassword
,[PasswordExp] = @PasswordExp
,[PasswordModifiedDate] = @PasswordModifiedDate
,[PasswordPolicyName] = @PasswordPolicyName
,[LoginTry] = @LoginTry
,[PermissionsRefreshDate] = @PermissionsRefreshDate
,[FirstName] = @FirstName
,[LastName] = @LastName
,[EmailAddress] = @EmailAddress
,[DefaultStoreId] = @DefaultStoreId
,[EmployeeNumber] = @EmployeeNumber
,[Phone] = @Phone
,[MobilePhone] = @MobilePhone
,[Address1] = @Address1
,[Address2] = @Address2
,[PostalCode] = @PostalCode
,[PostalAddress] = @PostalAddress
,[Title] = @Title
,[Language] = @Language
,[BirthDate] = @BirthDate
,[EmploymentDate] = @EmploymentDate
,[ResignationDate] = @ResignationDate
,[BankaccountNo] = @BankaccountNo
,[SocialSecurityNo] = @SocialSecurityNo
,[Comment] = @Comment
,[Country] = @Country
,[vudGUID] = @VudGUID
,[CreatedByUserId] = @CreatedByUserId
,[ModifiedByUserId] = @ModifiedByUserId
,[CreatedDate] = @CreatedDate
,[ModifiedDate] = @ModifiedDate
,[UseSingleSignOn] = @UseSingleSignOn
,[Salt] = @Salt
,[IsSystemUser] = @IsSystemUser`;
const subst = `[\1] = ISNULL(\2, [\1]),`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);