package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s+,?\[([A-Za-z0-9]+)\]\s=\s([A-Za-z0-9\@]+),?`)
var str = ` [UserLoginName] = @UserLoginName,
,[UserExternalId] = @UserExternalId
,[UserName] = @UserName
,[Password] = @Password
,[IsWindowsUser] = @IsWindowsUser
,[Active] = @IsActive
,[MustChangePassword] = @MustChangePassword
,[PasswordExp] = @PasswordExp
,[PasswordModifiedDate] = @PasswordModifiedDate
,[PasswordPolicyName] = @PasswordPolicyName
,[LoginTry] = @LoginTry
,[PermissionsRefreshDate] = @PermissionsRefreshDate
,[FirstName] = @FirstName
,[LastName] = @LastName
,[EmailAddress] = @EmailAddress
,[DefaultStoreId] = @DefaultStoreId
,[EmployeeNumber] = @EmployeeNumber
,[Phone] = @Phone
,[MobilePhone] = @MobilePhone
,[Address1] = @Address1
,[Address2] = @Address2
,[PostalCode] = @PostalCode
,[PostalAddress] = @PostalAddress
,[Title] = @Title
,[Language] = @Language
,[BirthDate] = @BirthDate
,[EmploymentDate] = @EmploymentDate
,[ResignationDate] = @ResignationDate
,[BankaccountNo] = @BankaccountNo
,[SocialSecurityNo] = @SocialSecurityNo
,[Comment] = @Comment
,[Country] = @Country
,[vudGUID] = @VudGUID
,[CreatedByUserId] = @CreatedByUserId
,[ModifiedByUserId] = @ModifiedByUserId
,[CreatedDate] = @CreatedDate
,[ModifiedDate] = @ModifiedDate
,[UseSingleSignOn] = @UseSingleSignOn
,[Salt] = @Salt
,[IsSystemUser] = @IsSystemUser`
var substitution = "[\1] = ISNULL(\2, [\1]),"
fmt.Println(re.ReplaceAllString(str, substitution))
}