import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s+,?\\[([A-Za-z0-9]+)\\]\\s=\\s([A-Za-z0-9\\@]+),?";
final String string = " [UserLoginName] = @UserLoginName, \n"
+ " ,[UserExternalId] = @UserExternalId\n"
+ " ,[UserName] = @UserName\n"
+ " ,[Password] = @Password\n"
+ " ,[IsWindowsUser] = @IsWindowsUser\n"
+ " ,[Active] = @IsActive\n"
+ " ,[MustChangePassword] = @MustChangePassword\n"
+ " ,[PasswordExp] = @PasswordExp\n"
+ " ,[PasswordModifiedDate] = @PasswordModifiedDate\n"
+ " ,[PasswordPolicyName] = @PasswordPolicyName\n"
+ " ,[LoginTry] = @LoginTry\n"
+ " ,[PermissionsRefreshDate] = @PermissionsRefreshDate\n"
+ " ,[FirstName] = @FirstName\n"
+ " ,[LastName] = @LastName\n"
+ " ,[EmailAddress] = @EmailAddress\n"
+ " ,[DefaultStoreId] = @DefaultStoreId\n"
+ " ,[EmployeeNumber] = @EmployeeNumber\n"
+ " ,[Phone] = @Phone\n"
+ " ,[MobilePhone] = @MobilePhone\n"
+ " ,[Address1] = @Address1\n"
+ " ,[Address2] = @Address2\n"
+ " ,[PostalCode] = @PostalCode\n"
+ " ,[PostalAddress] = @PostalAddress\n"
+ " ,[Title] = @Title\n"
+ " ,[Language] = @Language\n"
+ " ,[BirthDate] = @BirthDate\n"
+ " ,[EmploymentDate] = @EmploymentDate\n"
+ " ,[ResignationDate] = @ResignationDate\n"
+ " ,[BankaccountNo] = @BankaccountNo\n"
+ " ,[SocialSecurityNo] = @SocialSecurityNo\n"
+ " ,[Comment] = @Comment\n"
+ " ,[Country] = @Country\n"
+ " ,[vudGUID] = @VudGUID\n"
+ " ,[CreatedByUserId] = @CreatedByUserId\n"
+ " ,[ModifiedByUserId] = @ModifiedByUserId\n"
+ " ,[CreatedDate] = @CreatedDate\n"
+ " ,[ModifiedDate] = @ModifiedDate\n"
+ " ,[UseSingleSignOn] = @UseSingleSignOn\n"
+ " ,[Salt] = @Salt\n"
+ " ,[IsSystemUser] = @IsSystemUser";
final String subst = "[\\1] = ISNULL(\\2, [\\1]),";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}