package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<\s*block[^>]*>[^<]+Name\s+data3[^<]*<\s*\/\s*block\s*>`)
var str = `<block>
Name data1
Spec 36
</block>
<block id="data2">
Name data2
Spec 22
</block>
<block class="special">
Name data3
Spec 56
</block>
<block>
Name data4
Spec 41
</block>
<block>
Desc description of block1
Name data1
Spec 36
</block>
<block>
Desc a second description
Name data2
Spec 22
</block>
<block>
Desc something else
Name data3
Spec 56
</block>
<block>
Desc description of block4
Name data4
Spec 41
</block>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}