// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<\s*block[^>]*>[^<]+Name\s+data3[^<]*<\s*\/\s*block\s*>").unwrap();
let string = "<block>
Name data1
Spec 36
</block>
<block id=\"data2\">
Name data2
Spec 22
</block>
<block class=\"special\">
Name data3
Spec 56
</block>
<block>
Name data4
Spec 41
</block>
<block>
Desc description of block1
Name data1
Spec 36
</block>
<block>
Desc a second description
Name data2
Spec 22
</block>
<block>
Desc something else
Name data3
Spec 56
</block>
<block>
Desc description of block4
Name data4
Spec 41
</block>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}