$re = '/<\s*block[^>]*>[^<]+Name\s+data3[^<]*<\s*\/\s*block\s*>/';
$str = '<block>
Name data1
Spec 36
</block>
<block id="data2">
Name data2
Spec 22
</block>
<block class="special">
Name data3
Spec 56
</block>
<block>
Name data4
Spec 41
</block>
<block>
Desc description of block1
Name data1
Spec 36
</block>
<block>
Desc a second description
Name data2
Spec 22
</block>
<block>
Desc something else
Name data3
Spec 56
</block>
<block>
Desc description of block4
Name data4
Spec 41
</block>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);