import Foundation
let pattern = #"<\s*block[^>]*>[^<]+Name\s+data3[^<]*<\s*\/\s*block\s*>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<block>
Name data1
Spec 36
</block>
<block id="data2">
Name data2
Spec 22
</block>
<block class="special">
Name data3
Spec 56
</block>
<block>
Name data4
Spec 41
</block>
<block>
Desc description of block1
Name data1
Spec 36
</block>
<block>
Desc a second description
Name data2
Spec 22
</block>
<block>
Desc something else
Name data3
Spec 56
</block>
<block>
Desc description of block4
Name data4
Spec 41
</block>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)