const regex = /<\s*block[^>]*>[^<]+Name\s+data3[^<]*<\s*\/\s*block\s*>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\s*block[^>]*>[^<]+Name\\s+data3[^<]*<\\s*\\\/\\s*block\\s*>', 'g')
const str = `<block>
Name data1
Spec 36
</block>
<block id="data2">
Name data2
Spec 22
</block>
<block class="special">
Name data3
Spec 56
</block>
<block>
Name data4
Spec 41
</block>
<block>
Desc description of block1
Name data1
Spec 36
</block>
<block>
Desc a second description
Name data2
Spec 22
</block>
<block>
Desc something else
Name data3
Spec 56
</block>
<block>
Desc description of block4
Name data4
Spec 41
</block>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}