#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*\google\b)(?=.*\i\b).*|(?=.*\com\b).*" & @CRLF & _
""
Local $sString = " www.google.com/i.html" & @CRLF & _
" www.google.com" & @CRLF & _
" "www.google.com/g/i.com" & @CRLF & _
" "www.google.com" & @CRLF & _
" "www.google.th" & @CRLF & _
" "www.goo.com/i"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")