using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\google\b)(?=.*\i\b).*|(?=.*\com\b).*
";
string input = @" www.google.com/i.html
www.google.com
""www.google.com/g/i.com
""www.google.com
""www.google.th
""www.goo.com/i";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}