import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*\\google\\b)(?=.*\\i\\b).*|(?=.*\\com\\b).*\n";
final String string = " www.google.com/i.html\n"
+ " www.google.com\n"
+ " \"www.google.com/g/i.com\n"
+ " \"www.google.com\n"
+ " \"www.google.th\n"
+ " \"www.goo.com/i";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}