const regex = new RegExp('^(?=.*\\google\\b)(?=.*\\i\\b).*|(?=.*\\com\\b).*
', 'gm')
const str = ` www.google.com/i.html
www.google.com
"www.google.com/g/i.com
"www.google.com
"www.google.th
"www.goo.com/i`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}