re = /^(?=.*\google\b)(?=.*\i\b).*|(?=.*\com\b).*
/m
str = ' www.google.com/i.html
www.google.com
"www.google.com/g/i.com
"www.google.com
"www.google.th
"www.goo.com/i'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end