use strict;
my $str = ' www.google.com/i.html
www.google.com
"www.google.com/g/i.com
"www.google.com
"www.google.th
"www.goo.com/i';
my $regex = qr/^(?=.*\google\b)(?=.*\i\b).*|(?=.*\com\b).*
/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}