#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)width="(\d+)(px)?""
Local $sString = "│Арт │ Имя │Количество │Зак.цена │" & @CRLF & _
"├──────────┼───────────────────────────────────────────────┼───────┼─────────┤" & @CRLF & _
"<img width="30" height="auto" src="/descriptions/models/michelin/PilotSport5/40.jpg" class="pic_left">" & @CRLF & _
"<img width="30px" height="auto" src="/descriptions/models/michelin/PilotSport5/40.jpg" class="pic_left">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")