// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?u)width="(\d+)(px)?""#).unwrap();
let string = "│Арт │ Имя │Количество │Зак.цена │
├──────────┼───────────────────────────────────────────────┼───────┼─────────┤
<img width=\"30\" height=\"auto\" src=\"/descriptions/models/michelin/PilotSport5/40.jpg\" class=\"pic_left\">
<img width=\"30px\" height=\"auto\" src=\"/descriptions/models/michelin/PilotSport5/40.jpg\" class=\"pic_left\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}