import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "width=\"(\\d+)(px)?\"";
final String string = "│Арт │ Имя │Количество │Зак.цена │\n"
+ "├──────────┼───────────────────────────────────────────────┼───────┼─────────┤\n"
+ "<img width=\"30\" height=\"auto\" src=\"/descriptions/models/michelin/PilotSport5/40.jpg\" class=\"pic_left\">\n"
+ "<img width=\"30px\" height=\"auto\" src=\"/descriptions/models/michelin/PilotSport5/40.jpg\" class=\"pic_left\">";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}