using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"width=""(\d+)(px)?""";
string input = @"│Арт │ Имя │Количество │Зак.цена │
├──────────┼───────────────────────────────────────────────┼───────┼─────────┤
<img width=""30"" height=""auto"" src=""/descriptions/models/michelin/PilotSport5/40.jpg"" class=""pic_left"">
<img width=""30px"" height=""auto"" src=""/descriptions/models/michelin/PilotSport5/40.jpg"" class=""pic_left"">";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}