# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\+420|\+421)?[\s.-]?(\d{3})[\s.-](\d{3})[\s.-](\d{3})/<a href='tel:$1$2$3$4'>$1 $2 $3 $4<\/a>/mgu;t' <<< "tel.: +420 257 110 111
fax: +420 257 322 121
<br />tel.: 541 215 662<br />fax: 541 211 431<br />
<p>mob: 605 264 176</p>
<p>mobil: 731 154 552</p>
<p>tel.: 603 162 276</p>
"