use strict;
my $str = 'tel.: +420 257 110 111
fax: +420 257 322 121
<br />tel.: 541 215 662<br />fax: 541 211 431<br />
<p>mob: 605 264 176</p>
<p>mobil: 731 154 552</p>
<p>tel.: 603 162 276</p>
';
my $regex = qr/(\+420|\+421)?[\s.-]?(\d{3})[\s.-](\d{3})[\s.-](\d{3})/mup;
my $subst = '<a href=\'tel:$1$2$3$4\'>$1 $2 $3 $4</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";