#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mu)(\+420|\+421)?[\s.-]?(\d{3})[\s.-](\d{3})[\s.-](\d{3})"
Local $sString = "tel.: +420 257 110 111" & @CRLF & _
"fax: +420 257 322 121" & @CRLF & _
"<br />tel.: 541 215 662<br />fax: 541 211 431<br />" & @CRLF & _
"<p>mob: 605 264 176</p>" & @CRLF & _
"<p>mobil: 731 154 552</p>" & @CRLF & _
"<p>tel.: 603 162 276</p>" & @CRLF & _
""
Local $sSubst = "<a href='tel:$1$2$3$4'>$1 $2 $3 $4</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)