// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)(\+420|\+421)?[\s.-]?(\d{3})[\s.-](\d{3})[\s.-](\d{3})").unwrap();
let string = "tel.: +420 257 110 111
fax: +420 257 322 121
<br />tel.: 541 215 662<br />fax: 541 211 431<br />
<p>mob: 605 264 176</p>
<p>mobil: 731 154 552</p>
<p>tel.: 603 162 276</p>
";
let substitution = "<a href='tel:$1$2$3$4'>$1 $2 $3 $4</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}