import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\+420|\\+421)?[\\s.-]?(\\d{3})[\\s.-](\\d{3})[\\s.-](\\d{3})";
final String string = "tel.: +420 257 110 111\n"
+ "fax: +420 257 322 121\n"
+ "<br />tel.: 541 215 662<br />fax: 541 211 431<br />\n"
+ "<p>mob: 605 264 176</p>\n"
+ "<p>mobil: 731 154 552</p>\n"
+ "<p>tel.: 603 162 276</p>\n";
final String subst = "<a href='tel:$1$2$3$4'>$1 $2 $3 $4</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}