import re
regex = re.compile(r"(\+420|\+421)?[\s.-]?(\d{3})[\s.-](\d{3})[\s.-](\d{3})", flags=re.MULTILINE | re.UNICODE)
test_str = ("tel.: +420 257 110 111\n"
"fax: +420 257 322 121\n"
"<br />tel.: 541 215 662<br />fax: 541 211 431<br />\n"
"<p>mob: 605 264 176</p>\n"
"<p>mobil: 731 154 552</p>\n"
"<p>tel.: 603 162 276</p>\n")
subst = "<a href='tel:$1$2$3$4'>$1 $2 $3 $4</a>"
result = regex.sub(subst, test_str)
if result:
print(result)