# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*(?:ST|AVENUE|STREET)\b).*/\1/gm;t' <<< "9999 ST PAUL ST BSMT
GARRISON BL & BOARMAN AVENUE REAR
1234 MAIN STREET 123
1234 MAIN ST UNIT1"